<!DOCTYPE html>
<html lang="en-US">
<head>
<meta name="msvalidate.01" content="075A4D68E506EA5B12E55AA9D731FE3D" />
<meta name="description" content=" The Cup Scene Daily, The Voice of the NASCAR Nation! NASCAR news for the rest of us.">
<meta charset="UTF-8" />
<title>Edwards: ”I have no regrets, it’s been a blast” | CupScene.com</title>
<link rel="profile" href="http://gmpg.org/xfn/11" />
<link rel="stylesheet" type="text/css" media="all" href="http://cupscene.com/wp-content/themes/twentyten/style.css" />
<link rel="pingback" href="http://cupscene.com/xmlrpc.php" />
<link rel="alternate" type="application/rss+xml" title="CupScene.com &raquo; Feed" href="http://cupscene.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="CupScene.com &raquo; Comments Feed" href="http://cupscene.com/comments/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/72x72\/","ext":".png","source":{"concatemoji":"http:\/\/cupscene.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=4.4.5"}};
			!function(a,b,c){function d(a){var c,d,e,f=b.createElement("canvas"),g=f.getContext&&f.getContext("2d"),h=String.fromCharCode;return g&&g.fillText?(g.textBaseline="top",g.font="600 32px Arial","flag"===a?(g.fillText(h(55356,56806,55356,56826),0,0),f.toDataURL().length>3e3):"diversity"===a?(g.fillText(h(55356,57221),0,0),c=g.getImageData(16,16,1,1).data,g.fillText(h(55356,57221,55356,57343),0,0),c=g.getImageData(16,16,1,1).data,e=c[0]+","+c[1]+","+c[2]+","+c[3],d!==e):("simple"===a?g.fillText(h(55357,56835),0,0):g.fillText(h(55356,57135),0,0),0!==g.getImageData(16,16,1,1).data[0])):!1}function e(a){var c=b.createElement("script");c.src=a,c.type="text/javascript",b.getElementsByTagName("head")[0].appendChild(c)}var f,g;c.supports={simple:d("simple"),flag:d("flag"),unicode8:d("unicode8"),diversity:d("diversity")},c.DOMReady=!1,c.readyCallback=function(){c.DOMReady=!0},c.supports.simple&&c.supports.flag&&c.supports.unicode8&&c.supports.diversity||(g=function(){c.readyCallback()},b.addEventListener?(b.addEventListener("DOMContentLoaded",g,!1),a.addEventListener("load",g,!1)):(a.attachEvent("onload",g),b.attachEvent("onreadystatechange",function(){"complete"===b.readyState&&c.readyCallback()})),f=c.source||{},f.concatemoji?e(f.concatemoji):f.wpemoji&&f.twemoji&&(e(f.twemoji),e(f.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
<link rel='stylesheet' id='tubepress-css'  href='http://cupscene.com/wp-content/plugins/tubepress/src/main/web/css/tubepress.css?ver=4.4.5' type='text/css' media='all' />
<link rel='stylesheet' id='dcwp_plugin_admin_dcsmt_css-css'  href='http://cupscene.com/wp-content/plugins/social-media-tabs/css/admin.css?ver=4.4.5' type='text/css' media='all' />
<link rel='stylesheet' id='smooth_slider_headcss-css'  href='http://cupscene.com/wp-content/plugins/smooth-slider/css/skins/default/style.css?ver=2.3.5' type='text/css' media='all' />
<link rel='stylesheet' id='wspider-style-css'  href='http://cupscene.com/wp-content/plugins/weather-spider-display-weather-forecast-on-your-blog/jquery.weatherspider.css?ver=1.0' type='text/css' media='all' />
<link rel='stylesheet' id='youtube-channel-css'  href='http://cupscene.com/wp-content/plugins/youtube-channel/assets/css/youtube-channel.min.css?ver=3.0.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='magnific-popup-au-css'  href='http://cupscene.com/wp-content/plugins/youtube-channel/assets/lib/magnific-popup/magnific-popup.min.css?ver=3.0.7.1' type='text/css' media='all' />
<link rel='stylesheet' id='fpg-style-css'  href='http://cupscene.com/wp-content/plugins/featured-posts-grid/css/featured-posts-grid.css?ver=4.4.5' type='text/css' media='all' />
<link rel='stylesheet' id='fpg-style-dynamic-css'  href='http://cupscene.com/wp-content/plugins/featured-posts-grid/css/fpg.css.php?ver=4.4.5' type='text/css' media='all' />
<link rel='stylesheet' id='countdown-jedi-css-css'  href='http://cupscene.com/wp-content/plugins/jquery-t-countdown-widget/css/jedi/style.css?ver=1.1' type='text/css' media='all' />
<link rel='stylesheet' id='countdown-carbonite-css-css'  href='http://cupscene.com/wp-content/plugins/jquery-t-countdown-widget/css/carbonite/style.css?ver=1.1' type='text/css' media='all' />
<link rel='stylesheet' id='countdown-TIE-fighter-css-css'  href='http://cupscene.com/wp-content/plugins/jquery-t-countdown-widget/css/TIE-fighter/style.css?ver=1.1' type='text/css' media='all' />
<link rel='stylesheet' id='countdown-c-3po-css-css'  href='http://cupscene.com/wp-content/plugins/jquery-t-countdown-widget/css/c-3po/style.css?ver=1.1' type='text/css' media='all' />
<link rel='stylesheet' id='countdown-darth-css-css'  href='http://cupscene.com/wp-content/plugins/jquery-t-countdown-widget/css/darth/style.css?ver=1.1' type='text/css' media='all' />
<link rel='stylesheet' id='countdown-carbonlite-css-css'  href='http://cupscene.com/wp-content/plugins/jquery-t-countdown-widget/css/carbonlite/style.css?ver=1.1' type='text/css' media='all' />
<link rel='stylesheet' id='sideposts-css'  href='http://cupscene.com/wp-content/plugins/sideposts/style.css?ver=2.4.1' type='text/css' media='all' />
<script type="text/javascript" src='http://cupscene.com/wp-content/plugins/slidezoom/highslide/highslide.js'></script><link rel="stylesheet" type="text/css" href='http://cupscene.com/wp-content/plugins/slidezoom/highslide/highslide.css' /><script type="text/javascript">hs.graphicsDir= 'http://cupscene.com/wp-content/plugins/slidezoom/highslide/graphics/';hs.wrapperClassName="wide-border";</script><script type='text/javascript' src='http://cupscene.com/wp-includes/js/jquery/jquery.js?ver=1.11.3'></script>
<script type='text/javascript' src='http://cupscene.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.2.1'></script>
<script type='text/javascript' src='http://cupscene.com/wp-content/plugins/featured-posts-grid/js/fpg.js.php?ver=4.4.5'></script>
<script type='text/javascript' src='http://cupscene.com/wp-content/plugins/jquery-t-countdown-widget/js/jquery.t-countdown-1.0.js?ver=1.0'></script>
<script type='text/javascript' src='http://cupscene.com/wp-content/plugins/smooth-slider/js/jquery.jcarousel.min.js?ver=2.3.5'></script>
<script type='text/javascript' src='http://cupscene.com/wp-content/plugins/social-media-tabs/js/jquery.dcsmt.1.0.js?ver=4.4.5'></script>
<script type='text/javascript' src='http://cupscene.com/wp-content/plugins/tubepress/src/main/web/js/tubepress.js?ver=4.4.5'></script>
<script type='text/javascript' src='http://cupscene.com/wp-content/plugins/weather-spider-display-weather-forecast-on-your-blog/jquery.weatherspider.js?ver=1.0'></script>
<script type='text/javascript' src='http://cupscene.com/wp-content/plugins/countdown-timer/fergcorp_countdownTimer_java.js?ver=2.3.5'></script>
<script type='text/javascript' src='http://cupscene.com/wp-content/plugins/countdown-timer/webtoolkit.sprintf.js?ver=2.3.5'></script>
<link rel='https://api.w.org/' href='http://cupscene.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="http://cupscene.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="http://cupscene.com/wp-includes/wlwmanifest.xml" /> 
<link rel='prev' title='Stock car racing pioneer Raymond Parks set the standard during NASCAR’s early era' href='http://cupscene.com/stock-car-racing-pioneer-raymond-parks-set-the-standard-during-nascars-early-era/' />
<meta name="generator" content="WordPress 4.4.5" />
<link rel="canonical" href="http://cupscene.com/edwards-i-have-no-regrets-its-been-a-blast/" />
<link rel='shortlink' href='http://cupscene.com/?p=34481' />
<link rel="alternate" type="application/json+oembed" href="http://cupscene.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fcupscene.com%2Fedwards-i-have-no-regrets-its-been-a-blast%2F" />
<link rel="alternate" type="text/xml+oembed" href="http://cupscene.com/wp-json/oembed/1.0/embed?url=http%3A%2F%2Fcupscene.com%2Fedwards-i-have-no-regrets-its-been-a-blast%2F&#038;format=xml" />

	<!-- Added by EventCalendar plugin. Version 3.1.4 -->
	<script type='text/javascript' src='http://cupscene.com/wp-content/plugins/event-calender/xmlhttprequest.js'></script>
	<script type='text/javascript' src='http://cupscene.com/wp-content/plugins/event-calender/ec3.js'></script>
	<script type='text/javascript'><!--
	ec3.start_of_week=1;
	ec3.month_of_year=new Array('January','February','March','April','May','June','July','August','September','October','November','December');
	ec3.month_abbrev=new Array('Jan','Feb','Mar','Apr','May','Jun','Jul','Aug','Sep','Oct','Nov','Dec');
	ec3.myfiles='http://cupscene.com/wp-content/plugins/event-calender';
	ec3.home='http://cupscene.com';
	ec3.hide_logo=1;
	ec3.viewpostsfor="View posts for %1$s %2$s";
	// --></script>

<style type='text/css' media='screen'>
@import url(http://cupscene.com/wp-content/plugins/event-calender/ec3.css);
.ec3_ec {
 background-image:url(http://cupscene.com/wp-content/plugins/event-calender/ec.png) !IMPORTANT;
 background-image:none;
 filter:progid:DXImageTransform.Microsoft.AlphaImageLoader(src='http://cupscene.com/wp-content/plugins/event-calender/ec.png');
}
#ec3_shadow0 {
 background-image:url(http://cupscene.com/wp-content/plugins/event-calender/shadow0.png) !IMPORTANT;
 background-image:none;
}
#ec3_shadow0 div {
 filter:progid:DXImageTransform.Microsoft.AlphaImageLoader(src='http://cupscene.com/wp-content/plugins/event-calender/shadow0.png',sizingMethod='scale');
}
#ec3_shadow1 {
 background-image:url(http://cupscene.com/wp-content/plugins/event-calender/shadow1.png) !IMPORTANT;
 background-image:none;
 filter:progid:DXImageTransform.Microsoft.AlphaImageLoader(src='http://cupscene.com/wp-content/plugins/event-calender/shadow1.png',sizingMethod='crop');
}
#ec3_shadow2 {
 background-image:url(http://cupscene.com/wp-content/plugins/event-calender/shadow2.png) !IMPORTANT;
 background-image:none;
}
#ec3_shadow2 div {
 filter:progid:DXImageTransform.Microsoft.AlphaImageLoader(src='http://cupscene.com/wp-content/plugins/event-calender/shadow2.png',sizingMethod='scale');
}
</style>

<meta property="fb:app_id" content="109795289037231"/>
<link rel="stylesheet" href="http://cupscene.com/wp-content/plugins/featured-posts/featured-posts.css" type="text/css" media="screen" /><link rel="stylesheet" href="http://cupscene.com/wp-content/plugins/feedtube/feedtube.css" type="text/css" media="screen" /><!-- This site is powered by Tweet, Like, Plusone and Share Plugin - http://letusbuzz.com/tweet-share-like-plusone/ -->
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Edwards: ”I have no regrets, it’s been a blast”" />
	<meta property="og:url" content="http://cupscene.com/edwards-i-have-no-regrets-its-been-a-blast/"/>
	<meta property="og:site_name" content="CupScene.com" />
	<meta property="og:description" content="Carl Edwards confirmed Wednesday that his days as a full-time NASCAR driver are over. Continue reading &rarr; "/>
			<meta property="og:image" content="http://cupscene.com/wp-content/uploads/2017/01/carl2-600x319.jpg" />
	<style type="text/css">div.socialicons{float:left;display:block;margin-right: 10px;}div.socialicons p{margin-bottom: 0px !important;margin-top: 0px !important;padding-bottom: 0px !important;padding-top: 0px !important;}</style>
<style type="text/css" media="screen">.jcarousel-skin-default .jcarousel-clip-horizontal {padding:0px 20px 0px 20px;width:560px;}.smooth_slider{width:590px;height:240px;background-color:transparent;border:0px solid #999999;padding:0 5px 0 10px;}.sldr_title{font-family:Georgia, Arial, Helvetica, sans-serif;font-size:10px;font-weight:bold;font-style:normal;color:#000000;}.smooth_slider .jcarousel-item{width:560px;height:210px;}.smooth_slider h2{clear:none;line-height:23px;font-family:Trebuchet MS, Arial, Helvetica, sans-serif;font-size:20px;font-weight:bold;font-style:normal;color:#000000;margin:0px 0 5px 0 !important;}.smooth_slider h2 a{color:#000000;}.smooth_slider span{font-family:Verdana, Arial, Helvetica, sans-serif;font-size:12px;font-weight:normal;font-style:normal;color:#333333;}.smooth_slider_thumbnail{float:left;margin:0px 5px 0 0px;max-height:220px;border:0px solid #000000;}.smooth_slider .smooth_slideri div{margin-right:40px}.smooth_slider p.more a{color:#000000;font-family:Verdana, Arial, Helvetica, sans-serif;font-size:12px;}.jcarousel-control a{border:1px solid #333333;font-size:12px;font-family:Verdana, Arial, Helvetica, sans-serif;}.jcarousel-control a{color:#000000 !important;}.sldrlink{padding-right:10px;}.sldrlink a{color:#333333 !important;}</style>

<script type="text/javascript">var TubePressJsConfig = {"urls":{"base":"http:\/\/cupscene.com\/wp-content\/plugins\/tubepress","usr":"http:\/\/cupscene.com\/wp-content\/tubepress-content"}};</script>
<link rel="stylesheet" href="http://cupscene.com/wp-content/plugins/wp-content-slideshow/css/slide.css" type="text/css" media="screen" charset="utf-8"/>
<script type="text/javascript" src="http://cupscene.com/wp-content/plugins/wp-content-slideshow/scripts/jquery.cycle.js"></script>
<script type="text/javascript" src="http://cupscene.com/wp-content/plugins/wp-content-slideshow/scripts/slideshow.js"></script>
	
<link rel="stylesheet" href="http://cupscene.com/wp-content/plugins/wp-featured-content-slider/css/slide.css" type="text/css" media="screen" charset="utf-8"/>
<script type="text/javascript" src="http://cupscene.com/wp-content/plugins/wp-featured-content-slider/scripts/slider.js"></script>
	

<!-- WP Youtube Player 1.7 by unijimpe -->
<link rel='stylesheet' href='http://cupscene.com/wp-content/plugins/youtube-sidebar-widget/style.css' />
	<link rel="stylesheet" href="http://cupscene.com/wp-content/plugins/social-media-tabs/css/dcsmt.css" type="text/css" media="screen"  /><style type="text/css" id="custom-background-css">
body.custom-background { background-color: #181515; background-image: url('http://cupscene.com/wp-content/uploads/2012/03/default-background.jpg'); background-repeat: repeat; background-position: top center; background-attachment: fixed; }
</style>
<!-- Quantcast Tag -->
<script type="text/javascript">
var _qevents = _qevents || [];

(function() {
var elem = document.createElement('script');
elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
elem.async = true;
elem.type = "text/javascript";
var scpt = document.getElementsByTagName('script')[0];
scpt.parentNode.insertBefore(elem, scpt);
})();

_qevents.push({
qacct:"p-ccUinajqb7avM"
});
</script>

<noscript>
<div style="display:none;">
<img src="//pixel.quantserve.com/pixel/p-ccUinajqb7avM.gif" border="0" height="1" width="1" alt="Quantcast"/>
</div>
</noscript>
<!-- End Quantcast tag -->


</head>

<body class="single single-post postid-34481 single-format-standard custom-background">
<div id="wrapper" class="hfeed"> 
	<div id="header">
		<div id="masthead">
			<div id="branding" role="banner">
								<div id="site-title">
					<span>
						<a href="http://cupscene.com/" title="CupScene.com" rel="home">CupScene.com</a>
					</span>
				</div>
				<div id="site-description">Voice of the NASCAR Nation</div>

										<img src="http://cupscene.com/wp-content/uploads/2012/03/cropped-940x470.jpg" width="940" height="198" alt="" />
								</div></a><!-- #branding -->

			<div id="access" role="navigation">
			  				<div class="skip-link screen-reader-text"><a href="#content" title="Skip to content">Skip to content</a></div>
								<div class="menu-header"><ul id="menu-2016-series" class="menu"><li id="menu-item-27648" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-27648"><a href="http://cupscene.com/2016-nascar-season-schedules/">2016/2017 NASCAR Season Schedules</a>
<ul class="sub-menu">
	<li id="menu-item-31294" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31294"><a href="http://cupscene.com/2017-nascar-cup-series-schedule/">2017 NASCAR Cup Series Schedule</a></li>
	<li id="menu-item-31293" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31293"><a href="http://cupscene.com/2017-nascar-xfinity-series-schedule/">2017 NASCAR XFINITY Series Schedule</a></li>
	<li id="menu-item-31292" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31292"><a href="http://cupscene.com/2017-nascar-camping-world-truck-series-schedule/">2017 NASCAR Camping World Truck Series Schedule</a></li>
</ul>
</li>
<li id="menu-item-27784" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-27784"><a href="http://cupscene.com/2016-nascar-season-stats/">2016 NASCAR Season Stats</a>
<ul class="sub-menu">
	<li id="menu-item-31372" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31372"><a href="http://cupscene.com/2015-nascar-season-stats/">2015 NASCAR Season Stats</a></li>
	<li id="menu-item-31371" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31371"><a href="http://cupscene.com/2014-nascar-season-stats/">2014 NASCAR Season Stats</a></li>
	<li id="menu-item-31370" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-31370"><a href="http://cupscene.com/nascar-stats-2/">2013 NASCAR Season Stats</a></li>
</ul>
</li>
<li id="menu-item-7456" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-7456"><a href="http://cupscene.com/nascar-shop/">NASCAR Shop</a></li>
<li id="menu-item-1194" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1194"><a href="http://cupscene.com/nationwide-series-news/">Xfinity Series News</a></li>
<li id="menu-item-1193" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-1193"><a href="http://cupscene.com/truck-series-news/">Truck Series News</a></li>
<li id="menu-item-31380" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-31380"><a href="http://cupscene.com/press-releases/">Press Releases</a>
<ul class="sub-menu">
	<li id="menu-item-23697" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-23697"><a href="http://cupscene.com/photos-2/">Photos</a></li>
</ul>
</li>
</ul></div>			</div><!-- #access -->
		</div><!-- #masthead -->
	</div><!-- #header -->

	<div id="main">

		<div id="container">
			<div id="content" role="main">
<table width="980"> <tr><td width="819">
			
<div id="fb-root"></div>

			<script>(function(d, s, id) {

			  var js, fjs = d.getElementsByTagName(s)[0];

			  if (d.getElementById(id)) return;

			  js = d.createElement(s); js.id = id;

			  js.src = "//connect.facebook.net/en_US/all.js#xfbml=1";

			  fjs.parentNode.insertBefore(js, fjs);

			}(document, 'script', 'facebook-jssdk'));</script>
				<div id="nav-above" class="navigation">
					<div class="nav-previous"><a href="http://cupscene.com/stock-car-racing-pioneer-raymond-parks-set-the-standard-during-nascars-early-era/" rel="prev"><span class="meta-nav">&larr;</span> Stock car racing pioneer Raymond Parks set the standard during NASCAR’s early era</a></div>
					<div class="nav-next"></div>
				</div><!-- #nav-above -->

				<div id="post-34481" class="post-34481 post type-post status-publish format-standard has-post-thumbnail hentry category-main-page category-nascar-news category-top-stories tag-carl-edwards tag-nascar">
					<h1 class="entry-title">Edwards: ”I have no regrets, it’s been a blast”</h1>

					<div class="entry-meta">
						<span class="meta-prep meta-prep-author">Posted on</span> <a href="http://cupscene.com/edwards-i-have-no-regrets-its-been-a-blast/" title="11:16 am" rel="bookmark"><span class="entry-date">January 11, 2017</span></a> <span class="meta-sep">by</span> <span class="author vcard"><a class="url fn n" href="http://cupscene.com/author/admin/" title="View all posts by Greg Engle, CupScene.com Editor">Greg Engle, CupScene.com Editor</a></span>					</div><!-- .entry-meta -->

					<div class="entry-content">
						<div class="post_author_plugin"><span id="post_author_author"><font size="2">Written by:  Greg Engle, CupScene.com Editor, </font></span><span id="post_author_create">January 11, 2017<p></span></div><div class="social4i" style="height:29px;">
<div class="social4in" style="height:29px;float: left;">
<div class="socialicons s4twitter" style="float:left;margin-right: 10px;"><a href="https://twitter.com/share" data-url="http://cupscene.com/edwards-i-have-no-regrets-its-been-a-blast/" data-counturl="http://cupscene.com/edwards-i-have-no-regrets-its-been-a-blast/" data-text="Edwards: ”I have no regrets, it’s been a blast”" class="twitter-share-button" data-count="horizontal" data-via="Cupscene"></a><script type="text/javascript" src="https://platform.twitter.com/widgets.js"></script></div>
<div class="socialicons s4fblike" style="float:left;margin-right: 10px;">
<div id="fb-root"></div>
<p><script type="text/javascript" src="https://connect.facebook.net/en_US/all.js#xfbml=1"></script><fb:like href="http%3A%2F%2Fcupscene.com%2Fedwards-i-have-no-regrets-its-been-a-blast%2F" send="true" layout="button_count" width="100" height="21" show_faces="false" font=""></fb:like></div>
<div class="socialicons s4plusone" style="float:left;margin-right: 10px;"><script type="text/javascript" src="https://apis.google.com/js/plusone.js"></script><g:plusone size="medium" href="http://cupscene.com/edwards-i-have-no-regrets-its-been-a-blast/" count="true"></g:plusone></div>
<div class="socialicons s4linkedin" style="float:left;margin-right: 10px;"><script type="text/javascript" src="https://platform.linkedin.com/in.js"></script><script type="in/share" data-url="http://cupscene.com/edwards-i-have-no-regrets-its-been-a-blast/" data-counter="right"></script></div>
<div class="socialicons s4fbshare" style="position: relative;float:left;margin-right: 10px;">
<div class="s4ifbshare" ><a name="fb_share" type="button_count" share_url="http%3A%2F%2Fcupscene.com%2Fedwards-i-have-no-regrets-its-been-a-blast%2F" href="http://www.facebook.com/sharer.php"></a><script src="http://static.ak.fbcdn.net/connect.php/js/FB.Share" type="text/javascript"></script></div>
</div>
</div>
<div style="clear:both"></div>
</div>
<div id="attachment_34482" style="width: 1250px" class="wp-caption aligncenter"><img class="size-full wp-image-34482" src="http://cupscene.com/wp-content/uploads/2017/01/carl2.jpg" alt="Carl Edwards meets with the media Wednesday at Joe Gibbs Racing." width="1240" height="660" srcset="http://cupscene.com/wp-content/uploads/2017/01/carl2-300x160.jpg 300w, http://cupscene.com/wp-content/uploads/2017/01/carl2-768x409.jpg 768w, http://cupscene.com/wp-content/uploads/2017/01/carl2-600x319.jpg 600w, http://cupscene.com/wp-content/uploads/2017/01/carl2.jpg 1240w" sizes="(max-width: 1240px) 100vw, 1240px" /><p class="wp-caption-text">Carl Edwards meets with the media Wednesday at Joe Gibbs Racing.</p></div>
<p>Carl Edwards confirmed Wednesday that his days as a full-time NASCAR driver are over.  There were no shocking revelations, no health issues, or contract disputes.</p>
<p>“I’ve been racing for over 20 years,” Edwards said. “ I have no regrets, it’s been a blast.”</p>
<p>“I am truly personally satisfied with my career,” he added.</p>
<p>Edwards,37, said there were three reasons for walking away from the sport at a time when many argue he is at his peak.</p>
<p>“This is an all encompassing thing,” Edwards said about NASCAR. “We do this, its full time.”</p>
<p>Edwards is a native of Columbia Missouri. He worked his way up from the short tracks of the Midwest famously handing out business cards as he searched for a ride in NASCAR.  At the age of 22, Edwards made his NASCAR debut in the Truck Series with a team owned by Mike Mittler.  He moved to Roush-Fenway Racing in 2003 scoring his first win in the Truck Series race at Kentucky. He moved to the Xfinity Series with Roush in 2005 winning a total of 38 races along with the series title in 2007.</p>
<p>He also moved up to the Cup series in 2005 and amassed a total of 28 wins in 445 starts.  Five of those wins came in his two seasons with Joe Gibbs that started in 2015. He finished second in the season standings twice in 2008 and 2011.  The latter coming after an epic final race duel with Tony Stewart who won the title via a tiebreaker.  Edwards has kept his life away from the track private. He continues to live in Columbia with his wife Kate and two children.</p>
<p>“I think about (racing) all day,” Edwards said Wednesday. “I need to take that time right now, and devote it to people and things I care about.”</p>
<p>The second reason for stepping away is his health. Edwards is known for his strict workout regimen, and has appeared on the cover of fitness magazines.</p>
<p>“I still have my health,” he said.  “It’s A risky sport. I want to be a sharp guy in 30 years.”</p>
<p>As for the final reason Edwards said he’s ready for a life away from the grind of the NASCAR season which takes up nearly an entire year.</p>
<p>“I want to spend time on things outside the sport,” Edwards said Wednesday. “I have a lot of interests outside of racing; aviation, agriculture.”</p>
<p>As for saying he was retiring, Edwards hinted he might not be done competing in NASCAR.</p>
<p>“I’m not saying the “r” word here,” Edwards said. “But if I do I’m calling Joe Gibbs first.”</p>
<p>While he said he had no intention of returning full time, “If the right opportunity is there, then for sure I could, but the first person I would talk to is Coach. “</p>
<p>He said he really has no idea what he will be doing next.</p>
<p>“There’s no life raft I’m jumping on to,” he said. “I’m just jumping”</p>
<p>“No one is dangling a carrot out there,” he added.</p>
<p>Edwards was only 10 laps away from winning the 2016 Cup title. A crash on a late restart took him from the lead and out of championship contention. It turned out that it was probably Edwards last chance at winning a Cup title.  Edwards said Wednesday that leaving without a Cup title, isn’t a big heartbreak to him.</p>
<p>“With 30 laps to go,” Edwards said of the Homestead race. “That’s what I live for. We worked all year to be in that moment.  To be in that position, and know we were getting it done.  “</p>
<p>“For me personally I won.”</p>
<p>Edwards kept his emotions in check until nearly the end of the press conference.  He said he regretted being a “jerk” to his fellow drivers at times during his career. It is something he wants to change as he moves to the next part of his life.</p>
<p>“I just want to be a good person,” he said breaking down and taking a few moments to compose himself.</p>
<p>“I hope you’ll accept that I don’t’ have it all figured out yet,” Edwards said. “And I hope you know I am at peace with that.  Life’s short you have to do what your gut tells you.”</p>
<p>Team owner Joe Gibbs said he wasn’t expecting the news from Edwards.</p>
<p>“This was such a surprise,” Gibbs said. “I was all set for the holidays. I was in a meeting, and they said Carl stopped by.”</p>
<p>Gibbs said Edwards told him of his plans, and Gibbs told him to think about.  He said to spend some time with his family and get back to him.</p>
<p>&#8220;(He)took four days,” Gibbs said. “Then hooked up on the phone. I could tell he was fully committed.  “</p>
<p>Young Phenom Daniel Suarez was named as Edwards’ replacement driver in the No. 19 Toyota.</p>
<p>Suarez, a native of Mexico, burst onto the NASCAR scene in 2014. This past season he won 3 races in the Xfinity series and became the first Mexican driver to win a series title in one of NASCAR’s top three national touring series.</p>
<p>NASCAR Chairman &amp; CEO Brian France later released a statement:</p>
<p>“Carl Edwards has made an indelible mark on NASCAR. His hard-charging driving style has led to memorable moments that will live forever in the history of our sport. Carl’s passion and personality will greatly be missed – as will the signature backflips that NASCAR fans have come to expect following his victories. We wish Carl nothing but the best as he enters this next phase in life.”</p>
<!-- Facebook Comments for WordPress: http://pleer.co.uk/wordpress/plugins/facebook-comments/ --><div class="fbcomments"><h3>Comments</h3><div class="fb-comments" data-href="http://cupscene.com/edwards-i-have-no-regrets-its-been-a-blast/" data-num-posts="10" data-width="450" data-colorscheme="light"></div></div>											</div><!-- .entry-content -->


					<div class="entry-utility">
						This entry was posted in <a href="http://cupscene.com/category/main-page/" rel="category tag">Main Page</a>, <a href="http://cupscene.com/category/nascar-news/" rel="category tag">NASCAR News</a>, <a href="http://cupscene.com/category/top-stories/" rel="category tag">Top Stories</a> and tagged <a href="http://cupscene.com/tag/carl-edwards/" rel="tag">Carl Edwards</a>, <a href="http://cupscene.com/tag/nascar/" rel="tag">NASCAR</a>. Bookmark the <a href="http://cupscene.com/edwards-i-have-no-regrets-its-been-a-blast/" title="Permalink to Edwards: ”I have no regrets, it’s been a blast”" rel="bookmark">permalink</a>.											</div><!-- .entry-utility -->
				</div><!-- #post-## -->

				<div id="nav-below" class="navigation">
					<div class="nav-previous"><a href="http://cupscene.com/stock-car-racing-pioneer-raymond-parks-set-the-standard-during-nascars-early-era/" rel="prev"><span class="meta-nav">&larr;</span> Stock car racing pioneer Raymond Parks set the standard during NASCAR’s early era</a></div>
					<div class="nav-next"></div>
				</div><!-- #nav-below -->

				
			<div id="comments">


	<p class="nocomments">Comments are closed.</p>



</div><!-- #comments -->

  
</td><td width="160"> </div><!-- #content -->
<br><p align="center">
<a target="_blank" href="http://shareasale.com/r.cfm?b=826241&amp;u=147991&amp;m=62987&amp;urllink=&amp;afftrack="><img src="http://static.shareasale.com/image/62987/Daytona_Sweeps_125X125.jpg" border="0" alt="Save big this Cyber Weekend on official NASCAR fan gear and collectibles from Store.NASCAR.com" /></a>
</p><p align="left"><!-- start feedwind code --><script type="text/javascript">document.write('\x3Cscript type="text/javascript" src="' + ('https:' == document.location.protocol ? 'https://' : 'http://') + 'feed.mikle.com/js/rssmikle.js">\x3C/script>');</script><script type="text/javascript">(function() {var params = {rssmikle_url: "http://cupscene.com/feed/",rssmikle_frame_width: "200",rssmikle_frame_height: "400",frame_height_by_article: "0",rssmikle_target: "_blank",rssmikle_font: "Arial, Helvetica, sans-serif",rssmikle_font_size: "12",rssmikle_border: "off",responsive: "off",rssmikle_css_url: "",text_align: "left",text_align2: "justify",corner: "off",scrollbar: "on",autoscroll: "off",scrolldirection: "up",scrollstep: "3",mcspeed: "20",sort: "New",rssmikle_title: "on",rssmikle_title_sentence: "Latest Headlines",rssmikle_title_link: "",rssmikle_title_bgcolor: "#000814",rssmikle_title_color: "#FFFFFF",rssmikle_title_bgimage: "",rssmikle_item_bgcolor: "#FFFFFF",rssmikle_item_bgimage: "",rssmikle_item_title_length: "55",rssmikle_item_title_color: "#00112B",rssmikle_item_border_bottom: "on",rssmikle_item_description: "on",item_link: "on",rssmikle_item_description_length: "150",rssmikle_item_description_color: "#666666",rssmikle_item_date: "gl1",rssmikle_timezone: "Etc/GMT",datetime_format: "%b %e, %Y %l:%M:%S %p",item_description_style: "text+tn",item_thumbnail: "crop",item_thumbnail_selection: "auto",article_num: "15",rssmikle_item_podcast: "off",keyword_inc: "",keyword_exc: ""};feedwind_show_widget_iframe(params);})();</script><div style="font-size:10px; text-align:center; width:200px;"><a href="http://feed.mikle.com/" target="_blank" style="color:#CCCCCC;">RSS Feed Widget</a><!--Please display the above link in your web page according to Terms of Service.--></div><!-- end feedwind code --><p align="center"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- New 160 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:160px;height:600px"
     data-ad-client="ca-pub-9739132747570345"
     data-ad-slot="5377072246"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script></p>
</td></tr></table>
<p align="center">
<a target="_blank" href="http://shareasale.com/r.cfm?b=826240&amp;u=147991&amp;m=62987&amp;urllink=&amp;afftrack="><img src="http://static.shareasale.com/image/62987/Daytona_Sweeps_468X60.jpg" border="0" alt="Save big this Cyber Weekend on official NASCAR fan gear and collectibles from Store.NASCAR.com" /></a>
<div class="shrsl_ShareASale_productShowCaseTarget_16822"></div>
<script type="text/javascript"  src="http://showcase.shareasale.com/shareASale_liveWidget_loader.js?dt=11132016081200"></script>
<script type="text/javascript">shrsl_ShareASale_liveWid_Init(16822, 147991, 'shrsl_ShareASale_liveWid_product12_populate');</script> 
			</div><!-- #content -->
		</div><!-- #container -->


	</div><!-- #main -->
	<div id="footer" role="contentinfo">

		<div id="colophon">



			<div id="footer-widget-area" role="complementary">

				<div id="first" class="widget-area">
					<ul class="xoxo">
						<li id="text-22" class="widget-container widget_text"><h3 class="widget-title">Race Weather</h3>			<div class="textwidget"><!-- weather widget start --><div id="m-booked-bl-simple-week-vertical-96857"> <a href="//www.booked.net/weather/daytona-beach-18456" class="booked-wzs-160-275" style="background-color:#137AE9;"> <div class="booked-wzs-160-275-data wrz-01"> <div class="booked-wzs-160-275-right"> <div class="booked-wzs-day-deck"> <div class="booked-wzs-day-val"> <div class="booked-wzs-day-number"><span class="plus">+</span>80</div> <div class="booked-wzs-day-dergee"> <div class="booked-wzs-day-dergee-val">&deg;</div> <div class="booked-wzs-day-dergee-name">F</div> </div> </div> <div class="booked-wzs-day"> <div class="booked-wzs-day-d"><span class="plus">+</span>80&deg;</div> <div class="booked-wzs-day-n"><span class="plus">+</span>59&deg;</div> </div> </div> <div class="booked-wzs-160-275-city smolest">Daytona Beach</div> <div class="booked-wzs-160-275-date">Sunday, 13</div> </div> </div> <table cellpadding="0" cellspacing="0" class="booked-wzs-table-160"> <tr> <td class="week-day">Monday</td> <td class="week-day-ico"><div class="wrz-sml wrzs-03"></div></td> <td class="week-day-val"><span class="plus">+</span>72&deg;</td> <td class="week-day-val"><span class="plus">+</span>59&deg;</td> </tr> <tr> <td class="week-day">Tuesday</td> <td class="week-day-ico"><div class="wrz-sml wrzs-18"></div></td> <td class="week-day-val"><span class="plus">+</span>68&deg;</td> <td class="week-day-val"><span class="plus">+</span>55&deg;</td> </tr> <tr> <td class="week-day">Wednesday</td> <td class="week-day-ico"><div class="wrz-sml wrzs-01"></div></td> <td class="week-day-val"><span class="plus">+</span>71&deg;</td> <td class="week-day-val"><span class="plus">+</span>55&deg;</td> </tr> <tr> <td class="week-day">Thursday</td> <td class="week-day-ico"><div class="wrz-sml wrzs-01"></div></td> <td class="week-day-val"><span class="plus">+</span>77&deg;</td> <td class="week-day-val"><span class="plus">+</span>59&deg;</td> </tr> <tr> <td class="week-day">Friday</td> <td class="week-day-ico"><div class="wrz-sml wrzs-18"></div></td> <td class="week-day-val"><span class="plus">+</span>78&deg;</td> <td class="week-day-val"><span class="plus">+</span>69&deg;</td> </tr> <tr> <td class="week-day">Saturday</td> <td class="week-day-ico"><div class="wrz-sml wrzs-18"></div></td> <td class="week-day-val"><span class="plus">+</span>77&deg;</td> <td class="week-day-val"><span class="plus">+</span>72&deg;</td> </tr> </table> <div class="booked-wzs-center"> <span class="booked-wzs-bottom-l">See 7-Day Forecast</span> </div> </a> </div><script type="text/javascript"> var css_file=document.createElement("link"); css_file.setAttribute("rel","stylesheet"); css_file.setAttribute("type","text/css"); css_file.setAttribute("href",'//s.bookcdn.com/css/w/booked-wzs-widget-160x275.css?v=0.0.1'); document.getElementsByTagName("head")[0].appendChild(css_file); function setWidgetData(data) { if(typeof(data) != 'undefined' && data.results.length > 0) { for(var i = 0; i < data.results.length; ++i) { var objMainBlock = document.getElementById('m-booked-bl-simple-week-vertical-96857'); if(objMainBlock !== null) { var copyBlock = document.getElementById('m-bookew-weather-copy-'+data.results[i].widget_type); objMainBlock.innerHTML = data.results[i].html_code; if(copyBlock !== null) objMainBlock.appendChild(copyBlock); } } } else { alert('data=undefined||data.results is empty'); } } </script> <script type="text/javascript" charset="UTF-8" src="http://widgets.booked.net/weather/info?action=get_weather_info&ver=4&cityID=18456&type=4&scode=124&ltid=3458&domid=w209&cmetric=0&wlangID=1&color=137AE9&wwidth=250&header_color=ffffff&text_color=333333&link_color=08488D&border_form=1&footer_color=ffffff&footer_text_color=333333&transparent=0"></script><!-- weather widget end -->

<p align="center"> <a target="_blank" href="http://shareasale.com/r.cfm?b=826241&amp;u=147991&amp;m=62987&amp;urllink=&amp;afftrack="><img src="http://static.shareasale.com/image/62987/Daytona_Sweeps_125X125.jpg" border="0" alt="Save big this Cyber Weekend on official NASCAR fan gear and collectibles from Store.NASCAR.com" /></a></div>
		</li>					</ul>
				</div><!-- #first .widget-area -->

				<div id="second" class="widget-area">
					<ul class="xoxo">
						<li id="text-20" class="widget-container widget_text">			<div class="textwidget"><object classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=9,0,0,0" width="305" height="390" id="v5_widget_tabbed_fla8_1" align="middle">
 <param name="allowScriptAccess" value="always" />
 <param name="allowFullScreen" value="false" />
 <param name="movie" value="http://www.mrn.com/downloads/files/MRN/MRN_widget.swf" /><param name="quality" value="high" /><param name="bgcolor" value="#ffffff" />
<param name="wmode" value="transparent">  <embed src="http://www.mrn.com/downloads/files/MRN/MRN_widget.swf" quality="high" bgcolor="#ffffff" width="305" height="390" name="v5_widget_tabbed_fla8_1" align="middle" allowScriptAccess="always" allowFullScreen="false" type="application/x-shockwave-flash" wmode="transparent" pluginspage="http://www.macromedia.com/go/getflashplayer" />
 </object><br />
<a class="addthis_button" href="http://addthis.com/bookmark.php?v=250&username=iscinteractive"><img src="http://s7.addthis.com/static/btn/sm-share-en.gif" width="83" height="16" alt="Bookmark and Share" style="border:0"/></a></p>
<script type="text/javascript" src="http://s7.addthis.com/js/250/addthis_widget.js#username=iscinteractive"></script>
<script type="text/javascript">
var addthis_share = {
 title: "Motor Racing Network",
 description: "Motor Racing Network News Desk.",
 url: "http://www.mrn.com/",
 swfurl: "http://www.mrn.com/downloads/files/MRN/MRN_widget.swf",
 width: "305",
 height: "390",
 screenshot: "http://www.mrn.com/images/mrn_news_widget_screenshot.jpg"
 };
var addthis_config =
{
 username: 'iscinteractive',
 services_compact: 'facebook, myspace, igoogle, netvibes, squidoo, more',
 data_track_clickback: true,
 data_ga_tracker: 'UA-159551-2'
};
</script></div>
		</li>					</ul>
				</div><!-- #second .widget-area -->

				<div id="third" class="widget-area">
					<ul class="xoxo">
						<li id="text-23" class="widget-container widget_text">			<div class="textwidget"></div>
		</li>					</ul>
				</div><!-- #third .widget-area -->

				<div id="fourth" class="widget-area">
					<ul class="xoxo">
						<li id="text-18" class="widget-container widget_text"><h3 class="widget-title">Last Race</h3>			<div class="textwidget"><b>Ford #EcoBoost 400</b>
<br> Winner: Jimmie Johnson 
<br>Average Speed:  128.869 MPH
<br>Margin of Victory:  0.466 Seconds 
<br>Caution Flags:  7 for 33 laps
<br>Lead Changes:   20 among 6 drivers
<br> Time of race:  3 Hrs, 07 Mins, 10 Secs. 
<br><a target="_blank" href="http://www.cupscene.com/Statistics/112016RESULTS.pdf">RESULTS </a> <br><p align="right"><a href="http://cupscene.com/2016-nascar-season-stats/"> <b><i>All Season Stats>>></i></b></font>



<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- New 200 -->
<ins class="adsbygoogle"
     style="display:inline-block;width:200px;height:200px"
     data-ad-client="ca-pub-9739132747570345"
     data-ad-slot="5859286169"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>
</div>
		</li>					</ul>
				</div><!-- #fourth .widget-area -->

			</div><!-- #footer-widget-area -->

			<div id="site-info">
				<a href="http://cupscene.com/" title="CupScene.com" rel="home">
					CupScene.com				</a>
			</div><!-- #site-info -->

			<div id="site-generator">
				
			</div><!-- #site-generator -->

		</div><!-- #colophon -->
	</div><!-- #footer -->
</script><p align="center">


<!-- Ad Unit [14294] CupScene.com - 728x90 -->
<div id="switch_placeholder_2b58b4ee4c435e370ccd60ba5a0362bd" class="switch_placeholder"></div>
<script> (__scads = window.__scads || []).push({"z":14294,"targetId":"switch_placeholder_2b58b4ee4c435e370ccd60ba5a0362bd","domain":"delivery.switchadhub.com","width":"0","height":"0"}); </script>
<script async src="//delivery.switchadhub.com/adserver/sat.js?v=2"></script>

</p>
</div><!-- #wrapper -->
<script type="text/javascript">
<!--
var getOptions = new Array();
getOptions['showYear'] = 1;
getOptions['showMonth'] = 1;
getOptions['showWeek'] = 0;
getOptions['showDay'] = 1;
getOptions['showHour'] = 1;
getOptions['showMinute'] = 1;
getOptions['showSecond'] = 0;
getOptions['stripZero'] = 1;
var fergcorp_countdownTimer_js_language = new Array();
fergcorp_countdownTimer_js_language['year'] = '%d year, ';
fergcorp_countdownTimer_js_language['years'] = '%d years, ';
fergcorp_countdownTimer_js_language['month'] = '%d month, ';
fergcorp_countdownTimer_js_language['months'] = '%d months, ';
fergcorp_countdownTimer_js_language['week'] = '%d week, ';
fergcorp_countdownTimer_js_language['weeks'] = '%d weeks, ';
fergcorp_countdownTimer_js_language['day'] = '%d day, ';
fergcorp_countdownTimer_js_language['days'] = '%d days, ';
fergcorp_countdownTimer_js_language['hour'] = '%d hour, ';
fergcorp_countdownTimer_js_language['hours'] = '%d hours, ';
fergcorp_countdownTimer_js_language['minute'] = '%d minute, ';
fergcorp_countdownTimer_js_language['minutes'] = '%d minutes, ';
fergcorp_countdownTimer_js_language['second'] = '%d second, ';
fergcorp_countdownTimer_js_language['seconds'] = '%d seconds, ';
fergcorp_countdownTimer_js_language['ago'] = '%s ago';
fergcorp_countdownTimer_js_language['in'] = 'in %s';
var fergcorp_countdownTimer_js_events = new Array();
fergcorp_countdownTimer_js();
//-->
</script>
<script type="text/javascript">
			jQuery(".wspider").weatherspider({            
				"weatherCacheScript"      : "http://cupscene.com/wp-content/plugins/weather-spider-display-weather-forecast-on-your-blog/localWeatherService.php"
		  	});
		  </script><script type='text/javascript' src='http://cupscene.com/wp-content/plugins/youtube-sidebar-widget/script.js'></script><script type='text/javascript' src='http://cupscene.com/wp-includes/js/comment-reply.min.js?ver=4.4.5'></script>
<script type='text/javascript' src='http://cupscene.com/wp-content/plugins/youtube-channel/assets/lib/magnific-popup/jquery.magnific-popup.min.js?ver=3.0.7.1'></script>
<script type='text/javascript' src='http://cupscene.com/wp-content/plugins/youtube-channel/assets/js/youtube-channel.min.js?ver=3.0.7.1'></script>
<script type='text/javascript' src='http://cupscene.com/wp-includes/js/wp-embed.min.js?ver=4.4.5'></script>
<script>
  (function(i,s,o,g,r,a,m){i['GoogleAnalyticsObject']=r;i[r]=i[r]||function(){
  (i[r].q=i[r].q||[]).push(arguments)},i[r].l=1*new Date();a=s.createElement(o),
  m=s.getElementsByTagName(o)[0];a.async=1;a.src=g;m.parentNode.insertBefore(a,m)
  })(window,document,'script','//www.google-analytics.com/analytics.js','ga');

  ga('create', 'UA-2441290-1', 'auto');
  ga('send', 'pageview');

</script>
</body>
</html>
